Search found 248 matches

by HaydnW92
Sun Nov 01, 2020 7:12 pm
Forum: Technical
Topic: Alfa164Diagnostics
Replies: 221
Views: 230943

Re: Alfa164Diagnostics

Alfan, you're right. Hopefully if someone else encounters the one in the link I posted, they'll find this thread and try the other ones instead.

Thanks. :)

Haydn
by HaydnW92
Sun Nov 01, 2020 6:08 pm
Forum: Technical
Topic: Alfa164Diagnostics
Replies: 221
Views: 230943

Re: Alfa164Diagnostics

Hi guys, I noticed that the download link for the 164 diagnostics software is broken/unavailable. http://alfaromeo164register.com/diagnostics/index.php I'd like to download the software to help me to diagnose the ABS warning light on my 24v Cloverleaf. If anyone can provide it, or if the download li...
by HaydnW92
Tue Jun 16, 2020 4:40 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Thanks for the link but today I took delivery of my replacement (used) engine. So the project can progress once again!
by HaydnW92
Mon May 25, 2020 8:08 am
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Perfect, thanks for your help.
by HaydnW92
Sun May 24, 2020 8:34 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

I assume a 164 3.0 Super engine would work just fine, if I swap the external bits from my QV over? Am I right in saying that the engine in the Super is the same as the QV, the only differences are the intake runners and base plates? I know that with the earlier Qv with the 12v engine, there were int...
by HaydnW92
Sun May 24, 2020 8:06 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Wow, that's a really helpful post! Thank you!
by HaydnW92
Sun May 24, 2020 3:06 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

That's great info, exactly what I was looking for. Thanks! I'm considering rebuilding my engine and perhaps making some small improvements along the way. Cylinder head porting + skim for example. The only problem is that I don't have a workshop to work in, which isn't ideal for that sort of work rea...
by HaydnW92
Sat May 23, 2020 7:53 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Yeah I was surprised to be honest. The car has only covered 88k, but I guess a few different things could have happened to the internals over time. Eper part numbers - that's a good idea, thanks. Ideally I will find a suitable block with crank/pistons etc and fit my heads to it. If I do that, it mig...
by HaydnW92
Sat May 23, 2020 4:27 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Perhaps someone can tell me whether I can swap the bottom end from a 3.0 166 or GTV into my 164?
by HaydnW92
Fri May 22, 2020 5:29 pm
Forum: Wanted!
Topic: Wanted - engine for 164 24v QV
Replies: 0
Views: 4060

Wanted - engine for 164 24v QV

Hi, I'm looking for a replacement engine for my 1996 Alfa Romeo 164 3.0 24v Cloverleaf/QV. I don't mind if the cambelt needs to be changed but the engine must be in good condition. My current engine requires a bottom-end rebuild so I'm considering replacing it rather than rebuilding it. I may even c...
by HaydnW92
Fri May 22, 2020 3:35 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

I took the car for an MOT and it failed on a few things, some of which I already knew about and a couple of things that I didn't. Nothing major really. The big problem was that the engine has a problem. Each time I have started it up the engine has sounded a bit rough, but I was hoping this was just...
by HaydnW92
Thu Apr 30, 2020 3:36 pm
Forum: Technical
Topic: Alfa 164 3.0 V6 24V -94 engine transplant, fuelpump problem
Replies: 11
Views: 7327

Re: Alfa 164 3.0 V6 24V -94 engine transplant, fuelpump problem

Yeah that makes sense. I think you're right about the relay not receiving voltage with the ignition off but I will check this. Hopefully this will fix my problem.

Thanks for your responses.
by HaydnW92
Thu Apr 30, 2020 2:28 pm
Forum: Technical
Topic: Alfa 164 3.0 V6 24V -94 engine transplant, fuelpump problem
Replies: 11
Views: 7327

Re: Alfa 164 3.0 V6 24V -94 engine transplant, fuelpump problem

Thanks for your response. Yes, that's the exact same problem I'm having! It should be 0v on pin 85 but it gets 12v instead.

So you installed a permanent ground on pin 85 of the relay? I thought about doing that but I wondered if it would cause any problems?
by HaydnW92
Thu Apr 30, 2020 11:32 am
Forum: Technical
Topic: Alfa 164 3.0 V6 24V -94 engine transplant, fuelpump problem
Replies: 11
Views: 7327

Re: Alfa 164 3.0 V6 24V -94 engine transplant, fuelpump problem

I realise this thread is a few years old but did you ever find a solution to this issue? I'm having the exact same problem at the moment.
by HaydnW92
Thu Apr 30, 2020 10:42 am
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Thanks for the reply Alfisti-164. I have the original alarm but the control box in the boot is turned to off at the moment, so I'm not sure if that's the problem but you never know. How would I bypass it? Is it a case of disconnecting it and jumping some wires? I've been looking at my wiring diagram...
by HaydnW92
Wed Apr 29, 2020 1:31 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

My new relays arrived so I fitted them both but this has made no difference. I tried a different battery, just in case, but this also made no difference. I started to follow the non-starting diagnosis instructions from my workshop manual but this just led to more confusion as it seemed to suggest th...
by HaydnW92
Fri Apr 24, 2020 1:35 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Still no luck with getting the 164 to run. I tested the crank sensor which showed roughly 840 ohms, which is within spec but doesn't necessarily mean the sensor isn't faulty. I noticed something interesting though. I have read that when the engine is turning over, the rev counter should register the...
by HaydnW92
Fri Apr 24, 2020 8:44 am
Forum: Wanted!
Topic: Wanted - Savali Badge(s)
Replies: 15
Views: 9145

Re: Wanted - Savali Badge(s)

I think you misunderstood my post. We aren't talking about the chrome S badge on the back of US-market 164s - we are talking about the badge that Fasani posted a picture of above, with the three coloured strips on the left side (though this badge is obviously worn). This badge is totally different t...
by HaydnW92
Thu Apr 23, 2020 7:47 am
Forum: Wanted!
Topic: Wanted - Savali Badge(s)
Replies: 15
Views: 9145

Re: Wanted - Savali Badge(s)

I'm not sure, I know the metal 'S' shaped badge was but I'm not sure about these ones posted above. Having said that, if you had a Savali car of any age I don't think these badges would look 'wrong'.
by HaydnW92
Wed Apr 22, 2020 10:42 pm
Forum: Wanted!
Topic: Wanted - Savali Badge(s)
Replies: 15
Views: 9145

Re: Wanted - Savali Badge(s)

Thanks for the notification CarFan but I no longer own the Savali-engined car. Hopefully somebody else will see this and buy them 👍
by HaydnW92
Sun Apr 19, 2020 9:22 am
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

I was wondering abiut that yesterday - thanks, I will check the resistances today. Hopefully it's something simple like that.
by HaydnW92
Sat Apr 18, 2020 1:22 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Well, I've fitted the new fuel pump but we're not out of the woods yet. The old pump was definitely seized - putting 12v straight to the pins on the fuel pump connector now results in a working pump. Great! However, the pump is receiving no voltage according to my multimeter. I removed the fuel pump...
by HaydnW92
Fri Apr 10, 2020 12:01 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

Thanks for that post - I've been there before with my old 164 Cloverleaf a few years ago so I'm vaguely familiar with that process but it's always handy to have it written down in detail. I had a faulty relay on that occasion, leading to the engine cutting out when hot (which I discovered while I wa...
by HaydnW92
Tue Mar 31, 2020 9:03 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

That's right, I'm sure it is pins 30 and 87. I tried that - still nothing from the pump!
by HaydnW92
Tue Mar 31, 2020 8:04 pm
Forum: General
Topic: 1996 Alfa 164 Cloverleaf (I'm back...)
Replies: 64
Views: 35457

Re: 1996 Alfa 164 Cloverleaf (I'm back...)

I took the relay out and cleaned the contacts. They were pretty clean already. With the ignition on, if I removed the relay and then put it back I could hear/feel the relay ticking so I assume it's OK.