Home Register Manuals 164 Forum Interactive Library
Login

 
 

Complete loss of Oil pressure from 3000 rpm upwards

For the technical things.

Complete loss of Oil pressure from 3000 rpm upwards

Postby Isus » Mon May 02, 2016 9:56 pm

On Saturday I had a freakish failure, I lost all oil pressure while driving on a motorway, at some 4000 rpm as I removed my foot from the accelerator pedal my oil pressure fell to almost zero ( from some 5 bar)

After stopping and letting it cool down a bit, I had normal oil pressure at idle and up to 3000rpm where it suddenly cuts off and falls to zero, if the engine is hot the oil pressure warning light sometimes goes on and stays on regardless of the rpm. If you shut the engine down and then start again the light goes off, yet there is almost no oil pressure.

The engine starts normally, runs normal, no noises, no gasket failure detectable, oil level is ok, water level OK, no shavings on the dipstick.

Anyone ever heard of something similar? The small and big end bearings have been changed some 10 000km ago.

1992 A2H TS 265 000km, Castrol edge 10-60
User avatar
Isus
 
Posts: 15
Joined: Wed Jan 28, 2015 9:31 pm
Location: Zagreb
Country: Croatia (hr)

Re: Complete loss of Oil pressure from 3000 rpm upwards

Postby Alfamuppet » Sun May 15, 2016 5:49 pm

Maybe a faulty oil pressure sender?
Alfa 164 Q4 Proteo Red
Alfamuppet
 
Posts: 96
Joined: Thu Mar 06, 2014 2:39 pm
Location: Weston Super Mare
Country: United Kingdom (uk)

Re: Complete loss of Oil pressure from 3000 rpm upwards

Postby Alfan » Mon May 16, 2016 5:04 pm

The oil pressure gauge started acting weird in my Q4 last winter. However, replacing the sender unit the behaviour is back to normal.
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 75.000km
User avatar
Alfan
Q4 owner
 
Posts: 1023
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: Complete loss of Oil pressure from 3000 rpm upwards

Postby Isus » Thu Mar 02, 2017 10:07 am

Well, one camshaft retainer was not tightened correctly, thus at a certain pressure I changed the gears in the oil pump, the front cover was too badly worn. Getting a new one was impossible, the ones from the super/155 don't fit.

So I changed the engine, the donor was Killergame's rusty TS, yet the engine is better than my ex.
User avatar
Isus
 
Posts: 15
Joined: Wed Jan 28, 2015 9:31 pm
Location: Zagreb
Country: Croatia (hr)

Re: Complete loss of Oil pressure from 3000 rpm upwards

Postby alfa east » Sat Apr 08, 2017 8:59 am

That's a a fairly comprehensive fix then!
User avatar
alfa east
3.0 V6 24V automatic
 
Posts: 1094
Joined: Sat Oct 24, 2009 10:26 am
Location: Bangkok
Country: Thailand (th)


Return to Technical

Who is online

Users browsing this forum: No registered users and 2 guests

cron