Home Register Manuals 164 Forum Interactive Library
Login

 
 

IAC / ICV / idle air control valve circuit problem

For the technical things.

IAC / ICV / idle air control valve circuit problem

Postby 75evo » Tue Dec 20, 2016 12:25 am

HI Guys,

I'm getting the 1-2-3-3 error code on my 164 LS. When I check the ICV with the engine running but plenum ports plugged, it's not spinning. Replaced it with another ICV, same behavior. Nothing. Check voltage and it was 0. But since this is a PWM circuit, I also. checked with an oscilloscope, nothing. Any pointers? This connects directly to the Motronic right? No relays?

Was told the relay for the IAC power is at front cross member close to the radiator. Any pointers other than this? No signal from the ecu to pulse the IAC worries me a bit.

Thanks
75evo
 
Posts: 3
Joined: Mon Dec 19, 2016 7:09 am

Re: IAC / ICV / idle air control valve circuit problem

Postby 75evo » Wed Jan 04, 2017 4:54 pm

Sorry I fixed this problem, the knock sensor and ICV connectors were swapped.

Now I have a different problem. 1255 cam sensor. Will not rev past 2000 rpm.
75evo
 
Posts: 3
Joined: Mon Dec 19, 2016 7:09 am

Re: IAC / ICV / idle air control valve circuit problem

Postby Alfan » Thu Jan 05, 2017 9:24 am

That could very well be the cam sensor failing. Several posts here and on alfabb refer to this one as causing different symptoms as to how the engine runs.
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 75.000km
User avatar
Alfan
Q4 owner
 
Posts: 1023
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)


Return to Technical

Who is online

Users browsing this forum: Google [Bot] and 1 guest