relay

Tell us what your searching for...
Post Reply
User avatar
164EVER
Posts: 246
Joined: Thu Feb 20, 2014 9:42 am
Location: SAVOIE

relay

Post by 164EVER » Wed May 24, 2017 6:08 am

I need the warning-turn lights relay for my TD SUPER 1993, it gets me crazy :evil: :twisted:

User avatar
AlfaWhiz
Posts: 400
Joined: Thu Feb 06, 2014 1:15 pm

Re: relay

Post by AlfaWhiz » Wed May 24, 2017 6:30 am

What is wrong? I had intermittent problems with mine and I have re-flowed (re-soldered) the connections of the base of the relay. You can see it after you open it, the cover comes off when you pry simultaneously from both sides. After this my turn signals work as they should, maybe worth giving it a try.
Last edited by AlfaWhiz on Mon May 29, 2017 7:50 am, edited 1 time in total.

User avatar
164EVER
Posts: 246
Joined: Thu Feb 20, 2014 9:42 am
Location: SAVOIE

Re: relay

Post by 164EVER » Mon May 29, 2017 6:31 am

AlfaWhiz wrote:What is wrong? I had intermittent problems with mine and I have re-flowed (re-soldered) the connections of the base of the relay. You can see it after you open it, the cover comes off then you pry simultaneously from both sides. After this my turn signals work as they should, maybe worth giving it a try.
Hello, thanks for answer, the problem is that hazard signal starts by itself at any moment, for exemple when driving, or when the car is stopped, or when its on parking place, during night or day, it starts and it makes wrong anti-theft signal and alarm, and empties battery if I don't care.
I've already open the relay but I did'nt see any problem at soldering, but you're right, I shall look at it again.
The damn is the price of that electronic bug, it costs 120 bloody EUROS. :evil: :twisted:

User avatar
AlfaWhiz
Posts: 400
Joined: Thu Feb 06, 2014 1:15 pm

Re: relay

Post by AlfaWhiz » Mon May 29, 2017 8:12 am

Wow, that's expensive... :roll:

I couldn't see any visual defects in mine either, but the turn signals began working only when I pressed on the relay. Just re-flow the solder joints at the base of the relay to be sure.

It is also possible that your hazards button is defective. Don't forget to check the button and all the wiring as well.

Good luck!

User avatar
Alfan
Q4 owner
Posts: 1109
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark

Re: relay

Post by Alfan » Mon May 29, 2017 4:50 pm

If it is ONLY the hazard lights coming on randomly, I am sure it is within the centre console!

I had the same problem and it turned out to be one of the circuit boards in the unit that was corroded, so don't expect that a new relay will change anything.
1994 Alfa Romeo 164 Q4 Proteo Rosso 550.000km
1989 Lancia Thema 8.32 Verde Indy 265kkm
2001 Alfa Romeo Spider 3.0 24V Blue Lightning 55kkm
2011 Alfa Romeo Giulietta Multiair TCT Bianco Pastello 140kkm
2015 Alfa Romeo 4C Rosso Competizione 85kkm

User avatar
164EVER
Posts: 246
Joined: Thu Feb 20, 2014 9:42 am
Location: SAVOIE

Re: relay

Post by 164EVER » Mon May 29, 2017 6:43 pm

Alfan wrote:If it is ONLY the hazard lights coming on randomly, I am sure it is within the centre console!

I had the same problem and it turned out to be one of the circuit boards in the unit that was corroded, so don't expect that a new relay will change anything.
Thanks, so I will follow your advice, I have another unit ready to use that will take its place soon. :)
The relay is well solded.
After I will look inside the unit to see if it will be possible to repair it. :?:
I think the issues are due to over-heating inside the unit :roll:

User avatar
164EVER
Posts: 246
Joined: Thu Feb 20, 2014 9:42 am
Location: SAVOIE

Re: relay

Post by 164EVER » Wed May 31, 2017 7:49 pm

Alfan wrote:If it is ONLY the hazard lights coming on randomly, I am sure it is within the centre console!

I had the same problem and it turned out to be one of the circuit boards in the unit that was corroded, so don't expect that a new relay will change anything.
Hello, I did it, and after that no more unwanted warning lights on, thanks Alfan :wink:

User avatar
Alfan
Q4 owner
Posts: 1109
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark

Re: relay

Post by Alfan » Wed May 31, 2017 8:10 pm

:mrgreen: :wink:
1994 Alfa Romeo 164 Q4 Proteo Rosso 550.000km
1989 Lancia Thema 8.32 Verde Indy 265kkm
2001 Alfa Romeo Spider 3.0 24V Blue Lightning 55kkm
2011 Alfa Romeo Giulietta Multiair TCT Bianco Pastello 140kkm
2015 Alfa Romeo 4C Rosso Competizione 85kkm

User avatar
164EVER
Posts: 246
Joined: Thu Feb 20, 2014 9:42 am
Location: SAVOIE

Re: relay

Post by 164EVER » Thu Jun 01, 2017 5:48 am

164EVER wrote:
Alfan wrote:If it is ONLY the hazard lights coming on randomly, I am sure it is within the centre console!

I had the same problem and it turned out to be one of the circuit boards in the unit that was corroded, so don't expect that a new relay will change anything.
Hello, I did it, and after that no more unwanted warning lights on, thanks Alfan :wink:
I had a look at the circuit board but I found some rust only on the diode pins.

User avatar
Alfan
Q4 owner
Posts: 1109
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark

Re: relay

Post by Alfan » Thu Jun 01, 2017 12:48 pm

Ok, I guess it could also be the button and the press functionality that is unstable. In mine it was corrosion.
1994 Alfa Romeo 164 Q4 Proteo Rosso 550.000km
1989 Lancia Thema 8.32 Verde Indy 265kkm
2001 Alfa Romeo Spider 3.0 24V Blue Lightning 55kkm
2011 Alfa Romeo Giulietta Multiair TCT Bianco Pastello 140kkm
2015 Alfa Romeo 4C Rosso Competizione 85kkm

Post Reply