Home Register Manuals 164 Forum Interactive Library
Login

 
 

1996 3L 24V ECU not connecting

For the technical things.

1996 3L 24V ECU not connecting

Postby justhb » Wed Mar 08, 2017 12:50 pm

Dear All,
I have an issue with my car. None of the recognised ECU reading software packages are connecting to the ECU - Multiecuscan, Alfa Diag or Alfa 164 Forum.

The ecu is communicating via the 'flashing' lights on dash system.

Has anybody else experienced this problem?

The ECU reference is 0 046 422 643 0
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Wed Mar 08, 2017 9:28 pm

I think that people who have tried the program found on this site have got it to work, though maybe not first time.

If you have no connection with any of the tools, my guess is that your setup is wrong, since the manual way works.
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby justhb » Wed Mar 08, 2017 10:58 pm

Up till now, three different people (including myself) have tried to connect with different cables and systems. I am wondering if the ECU has been tampered with at some point or if the wiring has been damaged.
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Thu Mar 09, 2017 2:40 pm

Then the only thing I can think of, is to measure if the wires from the ECU to the 3-pin diagnostic plug are ok. Since the manual method works, I still think the ECU is ok, but I don't know how the manual test system is working.
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby justhb » Wed Mar 15, 2017 2:35 pm

I have found out that the ecu was reprogrammed to an earlier version car as the immobiliser was removed owing to problems.
Would this cause an issue with the twin wire plug and there not being any signals being sent to it?
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Wed Mar 15, 2017 8:48 pm

I suggest you try the different versions of ECU's. I have no idea if the reprogramming would have impacted the pin layout.

However, I still suggest to measure the impedance of the 3 wires going to the diagnostic plug to verify it they are ok or not.
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby justhb » Fri Mar 17, 2017 11:22 pm

I am getting the ECU sent away for testing.
I hope that it isn't at fault! A repair is £285 + VAT!!

Does anyone have a spare I can buy?
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby justhb » Tue Mar 21, 2017 7:23 pm

Ive had the ECU tested and there are no problems with it.
So does anyone have any ideas why my twin wire plug connector isn't connecting to the ECU/Computer?
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Tue Mar 21, 2017 8:17 pm

I don't recall that you mention anything about issues with your car. Is it only connecting to the ECU that is not working?

Since the 'flashing' (manual) system is working, I still suggest that you measure the wires for the diagnostic plug. I don't really have other ideas to try out...
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby justhb » Wed Mar 22, 2017 8:58 am

I have a couple of issues-
1. The ECU not communicating via the plug
2. A recurrent fault - 1244. We have changed the EGR solenoid twice but the fault just returns after some poor running

I saw on another forum that a car had a similar problem and that the timing was out by one notch. same fault code 1244. The symptom were as 2 above. Also, the car doesn't seem to have the full power you would expect.

Has anyone else heard of the timing issue being a problem?
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Wed Mar 22, 2017 3:20 pm

The poor running could well be the timing that is off, no matter what it is definitely worth to get verified!

Mine does not have EGT, but I think that I have read about a connection between the error code and timing issues on alfabb.com

Also, I have tried driving my Q4 with the timing 2 notches off, that was not nice! So get the timing checked asap.
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby justhb » Mon Apr 10, 2017 10:36 pm

Hi
Does anyone have an Electrical circuit diagram from the 3L V6 24Valve on a 96-97 car?

In particular I need to know what the ECU terminals are used for as there is an anomaly on mine.

Also, can anyone confirm what the ECU reference should be for the car so that i can check if
the ECU I have is the correct one for the car?

Thanks
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Tue Apr 11, 2017 8:24 am

Have a look here

http://www.bosch-classic.com/en/interne ... sicht.html

Did you check the timing?
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Tue Apr 11, 2017 8:33 am

1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby justhb » Thu Apr 13, 2017 10:54 am

Hi Alfan
Thank you.
I managed to get the ECU pin connector details from the ECU testing company and hope that now we can establish what is going on. Interestingly there is an anomaly in the diagnostic wire colours between what is on the car and what the wiring diagram details. Is it possible that as my car is one of the last, the wiring was changed?

We have not checked the timing yet as Glenn wants to make sure the ECU issue is cleared first.

Cheers
J
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby Alfan » Mon Apr 24, 2017 4:28 pm

I am not surprised that wire colouring does not 100% correspond to the documentation, I believe this is fairly common in older Italian cars :roll: But of course, someone could have modified it.

Let us know what you find out!
1994 Alfa Romeo 164 Q4 Proteo Rosso 535.000km
1989 Lancia Thema 8.32 Verde Indy 260.000km
2015 Alfa Romeo 4C Rosso Competizione 60.000km
User avatar
Alfan
Q4 owner
 
Posts: 959
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Country: Denmark (dk)

Re: 1996 3L 24V ECU not connecting

Postby justhb » Wed Apr 26, 2017 9:35 am

All the wiring looks 'original' in the ECU loom part........ maybe they ran out of a certain colour!!
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm

Re: 1996 3L 24V ECU not connecting

Postby justhb » Sat May 06, 2017 11:35 am

Dear all
I really need some help.

Does anyone have some photos of their 164 24v ecu and the connectors?
My car seems to be at odds with the published wiring diagram!

Also, I could do with a replacement ECU
justhb
 
Posts: 12
Joined: Sun Oct 30, 2011 9:02 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 1 guest