Search found 1328 matches

by Alfan
Sun Nov 20, 2022 7:40 pm
Forum: Technical
Topic: Alfa code problems!
Replies: 13
Views: 10221

Re: Alfa code problems!

Great to hear that you found the (simple) fault, so the car is starting again, and thanks for sharing your findings ๐Ÿ‘
by Alfan
Wed Nov 16, 2022 3:32 pm
Forum: Introduce yourself
Topic: My fourth 164 cloverleaf
Replies: 4
Views: 87

Re: My fourth 164 cloverleaf

Looks good, from a distance at least. And yes, you get addicted when you have enjoyed how good they really drive ๐Ÿ€๐Ÿ˜Š
by Alfan
Sun Nov 13, 2022 9:09 pm
Forum: Introduce yourself
Topic: Another Swede
Replies: 8
Views: 162

Re: Another Swede

obenhaus wrote: โ†‘
Sun Nov 13, 2022 12:52 pm
So, you live closer to Hamburg as to the Pรคrs home :wink:
Sweden is a large country, not much further to Arese from here :D
by Alfan
Tue Oct 25, 2022 10:28 am
Forum: Small talks
Topic: KM count
Replies: 2
Views: 103

Re: KM count

Many more kilometers left in that - and they need to be driven ๐Ÿ˜Ž
by Alfan
Tue Oct 25, 2022 10:27 am
Forum: Introduce yourself
Topic: My fourth 164 cloverleaf
Replies: 4
Views: 87

Re: My fourth 164 cloverleaf

Welcome to the site and congratulations on yet another 164 ๐Ÿ‘

We always like to see photos of the cars, also updates on the progress of the projects ๐Ÿ˜Š
by Alfan
Mon Oct 10, 2022 9:00 pm
Forum: Technical
Topic: 164, 24v 1993, ECU error code 31
Replies: 5
Views: 160

Re: 164, 24v 1993, ECU error code 31

Difficult to say what would cause this, if the car is running normal. In the manual section, you can find the one for Motronic 1.7, test 'I' relates to faulty injectors or injector signals related to the ECU.
by Alfan
Tue Oct 04, 2022 8:54 pm
Forum: Introduce yourself
Topic: Another Swede
Replies: 8
Views: 162

Re: Another Swede

That is looking really good and great that it can now be driven again ๐Ÿ‘
by Alfan
Thu Sep 29, 2022 1:57 pm
Forum: For sale
Topic: I sell my Alfa Romeo 164 TURBO 2.0 with Spoiler and Overboost
Replies: 4
Views: 243

Re: I sell my Alfa Romeo 164 TURBO 2.0 with Spoiler and Overboost

Salve :)

That looks like a very well maintained 164 and a nice homepage to show it ๐Ÿ‘

I think it will be very difficult to value this, but I hope that you find an enthusiastic new owner, who will keep it in the same condition, while also using it :)
by Alfan
Thu Sep 29, 2022 1:53 pm
Forum: Introduce yourself
Topic: Good Morning from Poland.
Replies: 3
Views: 185

Re: Good Morning from Poland.

Welcome, Marek :)

Yes, please share some photos of your 164 :)
by Alfan
Thu Sep 29, 2022 1:52 pm
Forum: Introduce yourself
Topic: Another Swede
Replies: 8
Views: 162

Re: Another Swede

Welcome, Pรคr :)

Yes, please share photos of your car! ๐Ÿ˜Ž

Where in Sweden are you located? I am in Skรฅne.
by Alfan
Thu Sep 29, 2022 1:49 pm
Forum: Technical
Topic: clim hose alfa 147
Replies: 1
Views: 86

Re: clim hose alfa 147

Maybe try and contact one of the Dutch members directly, if you haven't gotten this solved?
by Alfan
Thu Sep 29, 2022 1:48 pm
Forum: Technical
Topic: 164, 24v 1993, ECU error code 31
Replies: 5
Views: 160

Re: 164, 24v 1993, ECU error code 31

Is this the engine ECU? Or another unit?
by Alfan
Thu Sep 29, 2022 1:47 pm
Forum: General
Topic: Some recent pics of my Q4
Replies: 12
Views: 19162

Re: Some recent pics of my Q4

Hi Robbin

Welcome to the site :)

The site was update some time ago, and some of the links to photos were unfortunately lost in that process.

I believe Alfamuppet still owns the car, so maybe he can update this thread with more photos...
by Alfan
Thu Sep 29, 2022 1:45 pm
Forum: General
Topic: Alfa 164 2.0 v6 tb - How many were made?
Replies: 1
Views: 54

Re: Alfa 164 2.0 v6 tb - How many were made?

Welcome to the site :)

I think somewhere the numbers produced of the specific versions have been shown, but I don't recall where. Be aware that the first 164 turbo were made with the Lancia 4-cyl 16V engine.
by Alfan
Thu Jun 09, 2022 8:59 pm
Forum: Technical
Topic: Fuel pump not working
Replies: 19
Views: 475

Re: Fuel pump not working

fred0664 wrote: โ†‘
Thu Jun 09, 2022 8:53 pm
i just finished a 1964 mustang
Nice 8)
by Alfan
Thu Jun 09, 2022 8:58 pm
Forum: Technical
Topic: Fuel pump not working
Replies: 19
Views: 475

Re: Fuel pump not working

I will also check if there is ignition because if there is no ignition, the pump does not start? Ignition is needed for the pump to run (for a few seconds). And when starting I think it requires that the ECU gets the correct signal, in order to activate the fuel pump - if that does not happen, no f...
by Alfan
Thu Jun 09, 2022 8:48 pm
Forum: Technical
Topic: Fuel pump not working
Replies: 19
Views: 475

Re: Fuel pump not working

A project car - but a nice one ๐Ÿ‘ I think you need to go through the electrical plugs and ground cables - also clean the pins on the relays and fuses and their sockets, as they might look ok, but corrosion is blocking connection. If you can make a video of what is happening, that could also be helpfu...
by Alfan
Thu Jun 09, 2022 8:30 pm
Forum: Technical
Topic: Fuel pump not working
Replies: 19
Views: 475

Re: Fuel pump not working

For the fuel pump I think there is only the relay directly to the pump, running shortly with ignition on (controlled by the engine ECU) and then on constantly when the engine is started. This is the plug for the pump you need to measure, does it provide 12V or not. So firstly you need to find out, i...
by Alfan
Thu Jun 09, 2022 7:49 pm
Forum: Technical
Topic: Fuel pump not working
Replies: 19
Views: 475

Re: Fuel pump not working

Ok, so what if you supply 12V directly to the pump, when it is placed in the car? If that works you should look at the wires supplying the pump,since you write that the relay is ok. Are you absolutely sure that the relay is ok? The pump should run for about 2 seconds when ignition is turned on, so i...
by Alfan
Wed Jun 08, 2022 8:10 pm
Forum: Technical
Topic: Fuel pump not working
Replies: 19
Views: 475

Re: Fuel pump not working

I am not sure if the fuel pump works in your car or not, since you write this:

"
...fuel pump not working :(
I checked the pump it works...
"

What are you referring to with 'the high pressure pump'?
by Alfan
Wed Jun 08, 2022 9:49 am
Forum: Projects
Topic: La Signora Bianca del 1990.
Replies: 8
Views: 16471

Re: La Signora Bianca del 1990.

Looking good ๐Ÿ‘
by Alfan
Wed Jun 08, 2022 9:46 am
Forum: Introduce yourself
Topic: ALFA 164 3L V6 24V QV
Replies: 1
Views: 191

Re: ALFA 164 3L V6 24V QV

Welcome to the site :)

Photos of your 164 are always welcome 8)
by Alfan
Wed Jun 08, 2022 9:46 am
Forum: Technical
Topic: Fuel pump not working
Replies: 19
Views: 475

Re: Fuel pump not working

Welcome to the site :)

So you are not getting fuel to the engine? Fuel filter blocked? Fuel pressure regulator? Is fuel pressure high enough?
by Alfan
Tue Jun 07, 2022 8:44 pm
Forum: Technical
Topic: 164 Q4 ABS Light
Replies: 16
Views: 459

Re: 164 Q4 ABS Light

I agree with what AlfaWhiz has written, and would rather focus on connections and wires. I do not recall how the diagnostic cabling is connected to the unit, but since you have established that the relays and pump motor are ok that way, maybe that could help narrowing down the area of interest. I as...
by Alfan
Wed May 25, 2022 7:20 pm
Forum: Technical
Topic: 164 Q4 ABS Light
Replies: 16
Views: 459

Re: 164 Q4 ABS Light

Removing the control unit is probably only the 5 screws for the black unit, one being grounding, sounds familiar. Definitely worth having a look and maybe cleaning it. The relays are most likely soldered on, but if you can connect the tester and run the pump, you should be able to find out if any of...