The problem air bag

For the technical things.
Post Reply
User avatar
lucky
Posts: 20
Joined: Sun Sep 16, 2012 6:09 am
Location: Sofia

The problem air bag

Post by lucky » Tue Feb 10, 2015 6:49 pm

Hi guys,
i have following problem with air bag.i was in the service for electrical problem and after their work the problem was removed.
But created a new. :evil: Flashed the lamp for airbag.I think I have a blown fuse,but do not know where.In the fuse box have not fuse for the air bag .
The old problem was with, a central on the window.

164 TD
Q4 owner
Posts: 1204
Joined: Fri May 29, 2009 3:13 pm
Location: Honselersdijk

Re: The problem air bag

Post by 164 TD » Tue Feb 10, 2015 7:17 pm

Once a fault is stored in the airbagsystem, it can only be reset by an Alfatester of by the program Wilco made.

Diagnostic software
TD en Q4 owner

Image

perry
Posts: 80
Joined: Fri Apr 19, 2013 1:42 am
Location: east sussex

Re: The problem air bag

Post by perry » Sat Feb 28, 2015 8:17 pm

There is a fuse under the center console in a relay that comes off a lead that is attatched to the air bag ecu, also in the same place. Boyh are worth checking .
As said the codes must be cleared first to verify the fault is gone.

User avatar
AlfaWhiz
Posts: 420
Joined: Thu Feb 06, 2014 1:15 pm

Re: The problem air bag

Post by AlfaWhiz » Sat Feb 28, 2015 8:39 pm

What is quite common in my experience is that when you disconnect the battery, often after reconnecting again the airbag light will be lit. The system detects a short circuit or some other disturbance caused by the loss (or sudden rise) of voltage and stores a fault code. If you look at the code it usually says "problem has been solved", but the airbag light is lit until you clear the codes as mentioned above.

User avatar
Alfan
Q4 owner
Posts: 1260
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Contact:

Re: The problem air bag

Post by Alfan » Sun Mar 01, 2015 8:33 am

mike.foxtrot wrote:What is quite common in my experience is that when you disconnect the battery, often after reconnecting again the airbag light will be lit. The system detects a short circuit or some other disturbance caused by the loss (or sudden rise) of voltage and stores a fault code. If you look at the code it usually says "problem has been solved", but the airbag light is lit until you clear the codes as mentioned above.
I have never experienced that on my 164.

However, disconnecting the instrument cluster and turning on the ignition, will cause the light to go on - and maybe even damage the ECU...
1994 Alfa Romeo 164 Q4 Proteo Rosso
1989 Lancia Thema 8.32 Verde Indy
2001 Alfa Romeo Spider 3.0 24V Blue Lightning
2015 Alfa Romeo 4C Rosso Competizione
2021 Alfa Romeo Giulia Sprint Anodized Blu
1980 Alfa Romeo Alfetta Blindata Bianco

User avatar
AlfaWhiz
Posts: 420
Joined: Thu Feb 06, 2014 1:15 pm

Re: The problem air bag

Post by AlfaWhiz » Sun Mar 01, 2015 9:56 am

Alfan wrote:I have never experienced that on my 164.
Really? I saw it already twice. Maybe I went too far saying it's common, or my understanding of what's causing it is wrong. Anyway, this was what I experienced, and it happened after reconnecting the battery. In any case, reading out the error code should help.

User avatar
sancho164
Posts: 13
Joined: Thu Jun 27, 2013 12:43 pm

Re: The problem air bag

Post by sancho164 » Tue Jul 07, 2015 8:11 pm

Alfan wrote: However, disconnecting the instrument cluster and turning on the ignition, will cause the light to go on - and maybe even damage the ECU...
I dont think so. There is just one cable from the SRS to the dashboard. It supplies the two bulbs AIR and BAG. There is no communication between the bulbs and the SRS module, it can't even suggest if these buls are damaged, or disconnected (or all instrument cluster is no available). Its impossible to damage the SRS module that way. :wink:
This is checked. I started the engine of my Super with no dashboard few times, and no problems yet. :)
1990 164 3.0 V6 AT, Azev C 16"
1996 164 2.0 TS Super, LPG, Azev A 17", Xenon 4300K, Momo leather

User avatar
Alfan
Q4 owner
Posts: 1260
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Contact:

Re: The problem air bag

Post by Alfan » Tue Jul 07, 2015 8:39 pm

sancho164 wrote:
Alfan wrote: However, disconnecting the instrument cluster and turning on the ignition, will cause the light to go on - and maybe even damage the ECU...
I dont think so. There is just one cable from the SRS to the dashboard. It supplies the two bulbs AIR and BAG. There is no communication between the bulbs and the SRS module, it can't even suggest if these buls are damaged, or disconnected (or all instrument cluster is no available). Its impossible to damage the SRS module that way. :wink:
This is checked. I started the engine of my Super with no dashboard few times, and no problems yet. :)
Well, I can only refer to what happened with my Q4. No light on before I did this, afterwards it was on, and the fault code was for the ECU, replacing it fixed it. So I can only suggest to not do this!
1994 Alfa Romeo 164 Q4 Proteo Rosso
1989 Lancia Thema 8.32 Verde Indy
2001 Alfa Romeo Spider 3.0 24V Blue Lightning
2015 Alfa Romeo 4C Rosso Competizione
2021 Alfa Romeo Giulia Sprint Anodized Blu
1980 Alfa Romeo Alfetta Blindata Bianco

User avatar
sancho164
Posts: 13
Joined: Thu Jun 27, 2013 12:43 pm

Re: The problem air bag

Post by sancho164 » Thu Jul 09, 2015 5:32 pm

Very strange, but with ALFAs everything is possible. :D
So,maybe you talk about the old SRS module, the bigger one, with the two shock sensors, and I"m talking about the newer version withouth sensors. :D
1990 164 3.0 V6 AT, Azev C 16"
1996 164 2.0 TS Super, LPG, Azev A 17", Xenon 4300K, Momo leather

User avatar
Romuald
Posts: 34
Joined: Thu Feb 17, 2011 10:28 pm
Location: Russia

Re: The problem air bag

Post by Romuald » Sat Apr 10, 2021 12:09 pm

Hi! I have an Alfa-tester and modules. It is required to extinguish the "airbag" lamp. Alpha 164Q4 '96 . I use the MA9A module. Right? I can't connect. What am I doing wrong? Please tell me.

Image

User avatar
Alfan
Q4 owner
Posts: 1260
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Contact:

Re: The problem air bag

Post by Alfan » Sat Apr 10, 2021 6:35 pm

Do you have any idea why the airbag light came on? It could be that the ECU is 'out-of-order', so that no connection is possible... Of course, there could be several other possibilities, but I would suggest that you try to get hold of another ECU and test that, because it could actually be the problem and then no diagnostic system will help you.

I had the same situation about 15 years ago (turned on ignition without the instrument cluster in the car - learning the hard way) and the airbag light came on. The garage could not connect to the system, so another ECU went in and problem was gone.
1994 Alfa Romeo 164 Q4 Proteo Rosso
1989 Lancia Thema 8.32 Verde Indy
2001 Alfa Romeo Spider 3.0 24V Blue Lightning
2015 Alfa Romeo 4C Rosso Competizione
2021 Alfa Romeo Giulia Sprint Anodized Blu
1980 Alfa Romeo Alfetta Blindata Bianco

User avatar
Romuald
Posts: 34
Joined: Thu Feb 17, 2011 10:28 pm
Location: Russia

Re: The problem air bag

Post by Romuald » Sat Apr 10, 2021 8:51 pm

Alfan wrote:
Sat Apr 10, 2021 6:35 pm
Do you have any idea why the airbag light came on? It could be that the ECU is 'out-of-order', so that no connection is possible... Of course, there could be several other possibilities, but I would suggest that you try to get hold of another ECU and test that, because it could actually be the problem and then no diagnostic system will help you.

I had the same situation about 15 years ago (turned on ignition without the instrument cluster in the car - learning the hard way) and the airbag light came on. The garage could not connect to the system, so another ECU went in and problem was gone.
Thanks for the answer! I do not know for what reason this lamp became active, I bought my car with this problem.

User avatar
Romuald
Posts: 34
Joined: Thu Feb 17, 2011 10:28 pm
Location: Russia

Re: The problem air bag

Post by Romuald » Mon May 31, 2021 9:04 pm

Hello everybody! I have new questions, I want to deal with the warning lamp airbag. 1) What resistance should the airbag have? 2) What has fallen apart in the steering wheel if the part of the wires that runs through the steering wheel has a short circuit?

[
[url=https://postimg.cc/6TchCnJV]Image[/url]


[url=https://postimg.cc/cKfRC8Bn]Image[/url]

User avatar
Alfan
Q4 owner
Posts: 1260
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Contact:

Re: The problem air bag

Post by Alfan » Tue Jun 01, 2021 7:06 pm

I cannot help you with your questions, but since there was a problem with the size of photos on this site, which should now be fixed, maybe you can repost the photos, so it is easier to see the details.
1994 Alfa Romeo 164 Q4 Proteo Rosso
1989 Lancia Thema 8.32 Verde Indy
2001 Alfa Romeo Spider 3.0 24V Blue Lightning
2015 Alfa Romeo 4C Rosso Competizione
2021 Alfa Romeo Giulia Sprint Anodized Blu
1980 Alfa Romeo Alfetta Blindata Bianco

User avatar
Romuald
Posts: 34
Joined: Thu Feb 17, 2011 10:28 pm
Location: Russia

Re: The problem air bag

Post by Romuald » Tue Jun 01, 2021 8:37 pm

[URL=http://www.radikal.ru]Image[/URL]

This device is located behind the steering wheel. Is it normal that the resistance is 0 everywhere?

[URL=http://www.radikal.ru]Image[/URL]

User avatar
Alfan
Q4 owner
Posts: 1260
Joined: Thu Oct 22, 2009 8:20 pm
Location: Denmark
Contact:

Re: The problem air bag

Post by Alfan » Mon Jun 07, 2021 8:34 am

Hmm... I guess there are still problems with photos on the board...
1994 Alfa Romeo 164 Q4 Proteo Rosso
1989 Lancia Thema 8.32 Verde Indy
2001 Alfa Romeo Spider 3.0 24V Blue Lightning
2015 Alfa Romeo 4C Rosso Competizione
2021 Alfa Romeo Giulia Sprint Anodized Blu
1980 Alfa Romeo Alfetta Blindata Bianco

Post Reply